About Digger XP

This is a new version of Digger. This version uses the engine of the original Digger (written by the Windmill software in 1982). This means that AI and gameplay similar to the original game is available (but there are lots of new things!).

The game suppors different game modes for one and two players. Some of them are came from the original Digger and some of them are really new.


Game Modes

Digger XP supports different game modes:

  • Single player modes:
    • Single player. Similar to the original Digger.
    • Gauntlet mode. Race against time. You are limited by the time and you have to get as many score points as you can.
  • Two player modes:
    • Two players. Similar to the original Digger 2-player mode. Every player plays alone. When he dies, the other player plays his own game. Life-by-life.
    • Two players simultaneous. Both players play simultaneously.


How to play Digger XP.

To complete the level you have to collect all emeralds or to kill all monsters on the level.

Game controls:

Player 1:

Move Digger: Arrow keys
Fire: Enter

Player 2 (in simultaneous mode):

Move Digger: F, C, V, B
Fire: 1

Other keys:

F10 - Exit


Scoring System

The scoring system of the Digger XP is similar to the original Digger. Here it goes:

Emerald
25 points

Eight consecutive emeralds (octave)
Extra 250 points

Gold
500 points

Killing a Nobbin or a Hobbin by shooting or hitting with a bag
250 points

Bonus
1,000 points

Eating a Nobbin or a Hobbin (In bonus mode)
200 points for first, 400 for 2nd, etc. (doubling each time). Still 250 for other methods of killing, though.

At every multiple of 20,000 points you get an extra life.


FAQ

Frequently Asked Questions

Q: What's the most you can score?

A: The maximum possible score on completion of level 1 is 8,650 plus 3,900 for every life used. I used to be able to repeatably obtain 8,650. The maximum possible score you can have by the end of level 2 is 19,925 if you don't die, so it is not possible to start level 3 with more than 2 lives in reserve. I have got maximum score on the first two levels a few times.

I haven't bothered to calculate similar statistics for the other levels, but I can if anyone's interested...

If you meant "What's the most you've ever scored", the answer is 75,975.

Q: What's the most anyone's ever scored?

A: Have a look at the Digger hall of fame on http://www.digger.org/fame.html to find the latest top scores. If you can do better than the 10th best person in the world, submit a recording of your game to Einar Johan (fame@digger.org).

Q: Can you give me some tips to improve my game?

A: The best I can do is suggest that you play back the recorded games in the hall of fame (http://www.digger.org/fame.html) - who better to get tips from than the world's best Digger players?!

Q: What other interesting things do you know about Digger?

A: (by Andrew Jenner) In my explorations of the code of the game, I have discovered lots of things which might be of interest to someone.

On each new level up to level 10:

  • The monsters arrive more frequently.
  • There are more monsters in total.
  • The number of monsters on screen at once increases.
  • The number of times nobbins have to cross to become hobbins decreases.
  • The monsters move slightly faster on average (their speed is actually random).
  • The monsters less frequently stop chasing you (they always chase you on level 6 and above).
  • Hobbins stay hobbins for longer.
  • Gold hangs around for less long.
  • Fire takes longer to recharge.
  • Bonus mode lasts for less long.

Levels above 10 use the same variables as level 10 but different layouts.

The level plan is 1-2-3-4-5-6-7-8-6-7-8 followed by the sequence 5-6-7-8 repeated 247 times. If you complete level 8 249 times, all the subsequent levels use the layout from level 5.

Gold (as in a broken bag) disappears very quickly if you dig underneath it.

Monsters going up change direction when there is a bag falling on them, but they do the same thing even if the bag is below them in the same column.

Player 2 (in two player mode, obviously) doesn't get the extra life until after multiples of 20,000. Player 1 (in either mode) gets it *at* multiples of 20,000.

The noise made when you complete a level is polyphonic if no background music has been played since the game was started.

The original game allocated enough resources for 6 monsters, but only 5 are on screen at any given time. By changing a single byte in the original executable, you could make all 6 appear at the same time.

When you get a game over and no high score, the screen used to flash between its two colour schemes for a while, but the original didn't do this on my 8086. Apparently it did on some other people's computers, though, so it must have been a hardware oddity. It was taking ages to get back to the title screen, so I removed it.

In the original, you couldn't collect more than 4 spare lives. If you got 60,000 points without dying, you wouldn't get an extra life at that point. Some people thought this was unfair, so in Digger Remastered I added an option (/U) to allow you to collect as many lives as you like. However, care should be exercised using this option if you intend to record a game for the hall of fame, since your score will be calculated as if you played by the original rules. So you might not have as many lives as you thought you did, and your game might finish sooner. A few people have been caught out by this.

There are no more extra lives to be had at or after the 1 million point mark. Although this was a bug in the original Digger (a kludge really - Windmill software never counted on anyone getting that far) I've kept it on in Digger Remastered to give an extra little bit of difficulty to anyone that good.


Req

System Requirements

  • Win 9x/ME/2000/XP
  • DirectX 8.0 and greater
  • Graphics card with 4Mb video memory or more
  • Sound card


Future Plans.

Here are some plans I want to realise in the future:

  • Make keys redefinition available in the digger launcher.
  • Add new game mode - "Challange". It will be similar to 2 player simulaneous mode, but there will be a winner at the end of the game (the player that got more score points). The game score will be, too.

I'm also planning to fix all bugs, too. Here is the list of known bugs.

If you have any ideas, please contact me.


Known Bugs.

Here are some bugs I know about and I hope to fix in future.

  • Eating field doesn't leave totally blank fields. Some points are left. (This doesn't influence on gameplay - it is a graphics bug only)
  • When the level completed and the gold is still falling, while waiting for it to fall the screen look terrible.
  • When the music is changed, all sounds playing are stopped.
  • Entering initials for hiscore table has some visual artifacts.
  • No tune played and no pause made when the level is completed.

If you've found a bug that not in this list, please contact me and describe the bug. I'll try to fix it in the nearest versions.


What's New

Version history.

1.0

[!]

Sound engine was totally re-written. Now Digger XP supports digital sounds and digital music. Sound themes are supported. [!] Graphics engine was totally re-written. The game uses 800x600x16bit display mode. Graphics themes are supported.
[+]

Title screen changes. Added mouse-controlled interface allowing you to select game mode, see "about" page and make other functions.
[+]

Digger now has his own launcher. You can configure the game there.
[+]

When you get score you see a nice picture showing how many points you've got.
[+]

Emeralds animation added.
[*]

In 2 player simultaneous mode, invulnerable mode appearance changed. Now digger doesn't blinks, in has a shield around himself.
[*]

BugFix: In 2 player simultaneous mode if one players is dead the points for killing a monster by a gold were added to the dead player too.
[*]

BugFix: In 2 player simultaneous mode the grave can't eat monsters in bonus mode any more.
[*]

BugFix: In 2 player simultaneous mode when respawning digger sometimes it made a fire shot.

P.S.: I've taken the sources of the WinDig (ver 2000/03/10) and wrote this version based on these sources.


Authors

Authors Team.

Digger XP

Slava Cherkasov - writing Digger XP, composing music, making graphics. Contact if you have any ideas about Digger XP, if you find any bugs or just want to say some words to the author. Mail: slava@gamesfolder.com.

Digger remastered

Andrew Jenner - done the GREAT work remastering original Digger. Has his own Digger site: www.digger.org

Tim Draper - ported Digger Remastered to Windows.


About Windmill Software

(This article is taken from Andrew Jenner's Digger help file)

Windmill software is based in Canada and run by Jo-Anne Kempe. They no longer publish games, but now specialize in software for property management systems and custom management information systems (MIS) software. If you would like more information about Jo-Anne's company and its international capabilities in housing and building/facility management in custom MIS projects, contact her at Canada 905 639 4515 or visit the Windmill Software website at www.windmill-software.com

Windmill published at least nine games between 1982 and 1984: "Video Trek 88", "Floppy Frenzy", "Moonbugs", "The Exterminator", "Styx", "Digger", "Conquest", "Rollo and the Brush Brothers" and "Attack on Altair". All these are available from the Digger website.

I wrote to Jo-Anne on a number of occasions but she never replied. However, there have been a few messages on the Digger Chat mailing list from an employee of Windmill Software. Edited highlights follow:

I met Jo-Anne at a tradeshow in Toronto called ORCA which is for retirement communities, a market that she currently sells her property management software to. I had Digger on my laptop when I was there so I asked her a few questions about it. Apparently she was at a gaming show in the early 80s when she had initially demoed digger to an audience. It was in its early stages with alot of bugs. Apparently the folk who did Dig- Dug stole the concept and beat Windmill to the gaming market. She said she hadn't seen the game in years and asked if she could play it on my laptop. You should have seen this. She completed the first 3 levels without even looking at the screen. She said that the algorithms are so well known to her since she created them. She could play just by the sound and music. Amazing!!! I will be seeing her again at an upcoming show so I'll let you know about our next meeting. P.S. the main influence for her games... drugs.

She didn't write all of the games. She did some coding but her husband at the time (now ex husband) did most of the real coding. Her nephew did most of the music. I think that the Styx concept was stolen from Qix but I don't know about the rest of the games.

We've got original artwork (by Russ Liota) and game boxes (Kapanese versions) in the office. Styx, Conquest, Rollo, etc... And some advertisements from PC Magazine. Cool stuff. JA is pleased with your Windows revamp of Digger. She's a bit disappointed with the sound but what can you do. She's interested to know where you got the other games esp. Video Trek since she doesn't even have the source for any of the games anymore.

She honestly doesn't play digger that much anymore and until she found your website she didn't even have the game. We're a real small company right now with 7 or 8 people but growing quickly. Jo-Anne is busy, you've got no idea. She works like 18 hour days trying to get this company into the US market so I can't imagine her spending anytime in this chat room. She does love to talk about the gaming era though. Here's my Windmill history of the day: All the games were done in their home, created and packaged, the whole process. Apparently their two dogs (Chip and Byte) were always laying on all the disks before they were packaged so pretty much each copy of their games had dog hair in it! JA and her husband had vanity plates on their cars - Hobbin and Nobbin!

Jo-Anne tells me that there was another game. Not sure if it had worldwide distribution or not, in fact, she can't remember the name of the game. She claims that it was very similar to Q-Bert but way cooler. The name of the game started with a "J" and may have had the word "jump" in it. I'll keep drilling her to see if she can come up with the name. Also, if you're up for it, Jo-Anne is interested to see if you can resurrect some game reviews that Windmill got in PC Magazine back in the 80's. They were really good reviews - published by Ziff-Davis.

The game described sounds like "J-Bird", but although that was out at around the right time (1983), it was published by Orion Software, written by Greg Kuperberg and "protected under the copyright laws of the United States of America". Also, the presentation is very different from the other Windmill games. The mystery deepens:

After talking to Jo-Anne it seems as though J-Bird was a Windmill game. It was written by her nephew, Ray, but that doesn't explain why the rights are owned by Greg Kuperberg.

I'm gonna sent an email to Jo-Anne's nephew Ray to see if he's got any more info on J-Bird. Jo-Anne says that if Greg Kuperberg's name is on J-Bird, that it's stolen cuz she's never heard of him. Windmill also did a whole pile of utilities in the early 80's as well. One was called Videograph 88 which could take any image off a computer screen and send it to printer. It was the best of it's kind and it was hand-compiled based on the 8086 macro-assembler. Apparently it got a really good write up in PC Magazine issue #2.

What an intriguing mystery! It looks like a case of plagiarism, but the question is how much of the game was plagiarised? Did Greg Kuperberg just take the name and concept and make the game from scratch (much like most Tetris clones are called "Tetris" - I'm guilty of this myself)? Did he patch his name into Ray's executable (unlikely, since he would also have had to patch in the Orion Software animation)? Was there some sort of deal between Ray and Greg? Could Greg Kuperberg be an alias?


Links

Internet Links

Official Digger XP resources:

Digger XP official homepage:
www.gamesfolder.com

Digger XP author:
soulburner@mail.ru

Other resources:

Andrew Jenner Digger's page
www.digger.org

Windmill Software
www.windmill-software.com